Courtesy Advisory: Global Ransomware Attack ("WannaCry" Ransomware Outbreak)
Incident Report for LunaTech
Resolved
We hope everyone was able to successfully patch their Windows desktops and servers and that no attack has reached your systems. This was a courtesy advisory of the WannaCry Ransomware Outbreak. This incident is now resolved.
Posted about 2 years ago. May 15, 2017 - 12:37 PDT
Identified
Perhaps you've seen the news today but in case you haven't LunaTech is alerting all clients and partners to a global ransomware strain that has so far hit 99 countries around the globe. LunaTech systems and services (such as Exchange) are protected against this vulnerability; however, you should be aware that your own Windows desktops and server systems may be at risk.

LunaTech recommends the following actions to our customers and partners:

1. Immediately update all Windows systems with the Microsoft patch MS17-010 (released this past March).
2. Notify your users to be extra vigilant as even clicking on a suspicious attachment could start a ransomware attack on your network.
3. Backup all data -- preferably off-site and in the cloud -- to allow rapid recovery in the event you do fall victim to a ransomware attack. Remember that with most cloud-based backup services, such as Box, DropBox, etc., you can roll-back to earlier versions of a specific file should you end up backing up an infected file.

We will close this Courtesy Advisory in 48 hours.
Posted about 2 years ago. May 12, 2017 - 20:53 PDT