MyPortal Login
Incident Report for LunaTech
Resolved
This incident has been resolved.
Posted over 1 year ago. Aug 17, 2017 - 16:57 PDT
Investigating
We are experiencing intermittent issues with the MyPortal login page (myphone.lunatechit.com). If you cannot reach the portal page, please refresh your browser and attempt to re-connect. We will keep you updated as more information is gathered regarding this issue. If you need assistance in making any changes during this issue please reach out to LunaTech Support. Thank you for your patience.
Posted over 1 year ago. Aug 17, 2017 - 10:33 PDT